What’s Vulnerable › Vulnerabilities

CVE-2021-32740: Regular Expression Denial of Service in Addressable templates

Description

Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. An uncontrolled resource consumption vulnerability exists after version 2.3.0 through version 2.7.0. Within the URI template implementation in Addressable, a maliciously crafted template may result in uncontrolled resource consumption, leading to denial of service when matched against a URI. In typical usage, templates would not normally be read from untrusted user input, but nonetheless, no previous security advisory for Addressable has cautioned against doing this. Users of the parsing capabilities in Addressable but not the URI template capabilities are unaffected. The vulnerability is patched in version 2.8.0. As a workaround, only create Template objects from trusted sources that have been validated not to produce catastrophic backtracking.

Affected products

How to fix

Upgrade to a fixed version: sporkmonger addressable 2.8.0; Rubygems Addressable 2.8.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32740 or the next vulnerability affects your stack