What’s Vulnerable › Vulnerabilities
CVE-2021-32758: Layout XML Arbitrary Code Fix
- Severity: critical (CVSS 9.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-27 · updated 2026-06-17
- Weakness: CWE-91
Description
OpenMage Magento LTS is an alternative to the Magento CE official releases. Prior to versions 19.4.15 and 20.0.11, layout XML enabled admin users to execute arbitrary commands via block methods. The latest OpenMage Versions up from v19.4.15 and v20.0.11 have this Issue patched.
Affected products
- Openmage: before 19.4.15; from 20.0.00 before 20.0.11 — fixed in 19.4.15, 20.0.11
How to fix
Upgrade to a fixed version: Openmage 19.4.15, 20.0.11. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.15
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.11
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-26rr-v2j2-25fh
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.15
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.11
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-26rr-v2j2-25fh
Get alerted when CVE-2021-32758 or the next vulnerability affects your stack