What’s Vulnerable › Vulnerabilities
CVE-2021-32764: YouTube Onebox susceptible to XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. In Discourse versions 2.7.5 and prior, parsing and rendering of YouTube Oneboxes can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. The issue is patched in `stable` version 2.7.6, `beta` version 2.8.0.beta3, and `tests-passed` version 2.8.0.beta3. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Affected products
- discourse: through 2.7.5; 2.8.0-beta1
References
- https://github.com/discourse/discourse/security/advisories/GHSA-9x4c-29xg-56hw
- https://github.com/discourse/discourse/security/advisories/GHSA-9x4c-29xg-56hw
Get alerted when CVE-2021-32764 or the next vulnerability affects your stack