What’s Vulnerable › Vulnerabilities
CVE-2021-32770: Basic-auth app bundle credential exposure in gatsby-source-wordpress
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Gatsby is a framework for building websites. The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the `auth: { }` section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run `gatsby clean` followed by a `gatsby build`. One may manually edit the app.js file post-build as a workaround.
Affected products
- gatsbyjs Gatsby-Source-Wordpress: before 4.0.8; from 5.0.0 before 5.9.2 — fixed in 4.0.8, 5.9.2
How to fix
Upgrade to a fixed version: gatsbyjs Gatsby-Source-Wordpress 4.0.8, 5.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-rqjw-p5vr-c695
- https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-rqjw-p5vr-c695
Get alerted when CVE-2021-32770 or the next vulnerability affects your stack