What’s Vulnerable › Vulnerabilities
CVE-2021-32771: Buffer overflow in contiki-ng
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-120
Description
Contiki-NG is an open-source, cross-platform operating system for IoT devices. In affected versions it is possible to cause a buffer overflow when copying an IPv6 address prefix in the RPL-Classic implementation in Contiki-NG. In order to trigger the vulnerability, the Contiki-NG system must have joined an RPL DODAG. After that, an attacker can send a DAO packet with a Target option that contains a prefix length larger than 128 bits. The problem was fixed after the release of Contiki-NG 4.7. Users unable to upgrade may apply the patch in Contiki-NG PR #1615.
Affected products
- contiki-ng: before 4.8 — fixed in 4.8
How to fix
Upgrade to a fixed version: contiki-ng 4.8. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/pull/1615
- https://github.com/contiki-ng/contiki-ng/pull/1615/commits/587ae59956e00316fd44fd7072ac3a6a07b4b20f
- https://github.com/contiki-ng/contiki-ng/releases/tag/release%2Fv4.8
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-jqjf-v7v9-xp6w
- https://github.com/contiki-ng/contiki-ng/pull/1615
- https://github.com/contiki-ng/contiki-ng/pull/1615/commits/587ae59956e00316fd44fd7072ac3a6a07b4b20f
- https://github.com/contiki-ng/contiki-ng/releases/tag/release%2Fv4.8
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-jqjf-v7v9-xp6w
Get alerted when CVE-2021-32771 or the next vulnerability affects your stack