What’s Vulnerable › Vulnerabilities
CVE-2021-32773: Confused deputy attack in sandbox module resolution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-20 · updated 2026-06-17
- Weakness: CWE-441
Description
Racket is a general-purpose programming language and an ecosystem for language-oriented programming. In versions prior to 8.2, code evaluated using the Racket sandbox could cause system modules to incorrectly use attacker-created modules instead of their intended dependencies. This could allow system functions to be controlled by the attacker, giving access to facilities intended to be restricted. This problem is fixed in Racket version 8.2. A workaround is available, depending on system settings. For systems that provide arbitrary Racket evaluation, external sandboxing such as containers limit the impact of the problem. For multi-user evaluation systems, such as the `handin-server` system, it is not possible to work around this problem and upgrading is required.
Affected products
- racket: before 8.2 — fixed in 8.2
How to fix
Upgrade to a fixed version: racket 8.2. Check the vendor advisory for mitigations.
References
- https://github.com/racket/racket/commit/6ca4ffeca1e5877d44f835760ad89f18488d97e1
- https://github.com/racket/racket/security/advisories/GHSA-cgrw-p7p7-937c
- https://github.com/racket/racket/commit/6ca4ffeca1e5877d44f835760ad89f18488d97e1
- https://github.com/racket/racket/security/advisories/GHSA-cgrw-p7p7-937c
Get alerted when CVE-2021-32773 or the next vulnerability affects your stack