What’s Vulnerable › Vulnerabilities
CVE-2021-32777: Incorrect concatenation of multiple value request headers in ext-authz extension
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-24 · updated 2026-06-17
- Weakness: CWE-551
Description
Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In affected versions when ext-authz extension is sending request headers to the external authorization service it must merge multiple value headers according to the HTTP spec. However, only the last header value is sent. This may allow specifically crafted requests to bypass authorization. Attackers may be able to escalate privileges when using ext-authz extension or back end service that uses multiple value headers for authorization. A specifically constructed request may be delivered by an untrusted downstream peer in the presence of ext-authz extension. Envoy versions 1.19.1, 1.18.4, 1.17.4, 1.16.5 contain fixes to the ext-authz extension to correctly merge multiple request header values, when sending request for authorization.
Affected products
- envoyproxy envoy: from 1.16.0 before 1.16.5; from 1.17.0 before 1.17.4; from 1.18.0 before 1.18.4; 1.19.0 — fixed in 1.16.5, 1.17.4, 1.18.4
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.16.5, 1.17.4, 1.18.4. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-6g4j-5vrw-2m8h
- https://www.envoyproxy.io/docs/envoy/v1.19.0/version_history/version_history
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-6g4j-5vrw-2m8h
- https://www.envoyproxy.io/docs/envoy/v1.19.0/version_history/version_history
Get alerted when CVE-2021-32777 or the next vulnerability affects your stack