What’s Vulnerable › Vulnerabilities
CVE-2021-32782: Cross-Site Scripting in Nextcloud Circles
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Nextcloud Circles is an open source social network built for the nextcloud ecosystem. In affected versions the Nextcloud Circles application is vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Circles application is upgraded to 0.21.3, 0.20.10 or 0.19.14 to resolve this issue. As a workaround users may use a browser that has support for Content-Security-Policy. A notable exemption is Internet Explorer which does not support CSP properly.
Affected products
- Nextcloud Circles: before 0.19.14; from 0.20.0 before 0.20.10; from 0.21.0 before 0.21.3 — fixed in 0.19.14, 0.20.10, 0.21.3
How to fix
Upgrade to a fixed version: Nextcloud Circles 0.19.14, 0.20.10, 0.21.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9
- https://hackerone.com/reports/1217606
- https://github.com/nextcloud/circles/commit/dbb97a83ccb342c839a54f088aa19b8ba6844b0e
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-hgpq-28gj-jrj9
- https://hackerone.com/reports/1217606
Get alerted when CVE-2021-32782 or the next vulnerability affects your stack