What’s Vulnerable › Vulnerabilities
CVE-2021-32790: Blind SQL Injection possible via Authenticated Web-hook Search API Endpoint
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-26 · updated 2026-06-17
- Weakness: CWE-89
Description
Woocommerce is an open source eCommerce plugin for WordPress. An SQL injection vulnerability impacts all WooCommerce sites running the WooCommerce plugin between version 3.3.0 and 3.3.6. Malicious actors (already) having admin access, or API keys to the WooCommerce site can exploit vulnerable endpoints of `/wp-json/wc/v3/webhooks`, `/wp-json/wc/v2/webhooks` and other webhook listing API. Read-only SQL queries can be executed using this exploit, while data will not be returned, by carefully crafting `search` parameter information can be disclosed using timing and related attacks. Version 3.3.6 is the earliest version of Woocommerce with a patch for this vulnerability. There are no known workarounds other than upgrading.
Affected products
- Automattic WooCommerce: from 3.3.0 before 3.3.6; from 3.4.0 before 3.4.8; from 3.5.0 before 3.5.9; from 3.6.0 before 3.6.6; from 3.7.0 before 3.7.2; from 3.8.0 before 3.8.2 — fixed in 3.3.6, 3.4.8, 3.5.9, 3.6.6, 3.7.2, 3.8.2
How to fix
Upgrade to a fixed version: Automattic WooCommerce 3.3.6, 3.4.8, 3.5.9, 3.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-7vx5-x39w-q24g
- https://woocommerce.com/posts/critical-vulnerability-detected-july-2021/
- https://github.com/woocommerce/woocommerce/security/advisories/GHSA-7vx5-x39w-q24g
- https://woocommerce.com/posts/critical-vulnerability-detected-july-2021/
Get alerted when CVE-2021-32790 or the next vulnerability affects your stack