What’s Vulnerable › Vulnerabilities
CVE-2021-32793: Stored XSS Vulnerability in the Pi-hole Webinterface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Pi-hole's Web interface provides a central location to manage a Pi-hole instance and review performance statistics. Prior to Pi-hole Web interface version 5.5.1, the function to add domains to blocklists or allowlists is vulnerable to a stored cross-site-scripting vulnerability. User input added as a wildcard domain to a blocklist or allowlist is unfiltered in the web interface. Since the payload is stored permanently as a wildcard domain, this is a persistent XSS vulnerability. A remote attacker can therefore attack administrative user accounts through client-side attacks. Pi-hole Web Interface version 5.5.1 contains a patch for this vulnerability.
Affected products
- pi-hole: before 5.5.1 — fixed in 5.5.1
How to fix
Upgrade to a fixed version: pi-hole 5.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pi-hole/AdminLTE/releases/tag/v5.5.1
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-g3w6-q4fg-p8x8
- https://github.com/pi-hole/AdminLTE/releases/tag/v5.5.1
- https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-g3w6-q4fg-p8x8
Get alerted when CVE-2021-32793 or the next vulnerability affects your stack