What’s Vulnerable › Vulnerabilities
CVE-2021-32800: Bypass of Two Factor Authentication in Nextcloud server
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-306
Description
Nextcloud server is an open source, self hosted personal cloud. In affected versions an attacker is able to bypass Two Factor Authentication in Nextcloud. Thus knowledge of a password, or access to a WebAuthN trusted device of a user was sufficient to gain access to an account. It is recommended that the Nextcloud Server is upgraded to 20.0.12, 21.0.4 or 22.1.0. There are no workaround for this vulnerability.
Affected products
- Nextcloud Server: before 20.0.12; from 21.0.0 before 21.0.4; from 22.0.0 before 22.1.0 — fixed in 20.0.12, 21.0.4, 22.1.0
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.12, 21.0.4, 22.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v
- https://github.com/nextcloud/server/pull/28078
- https://hackerone.com/reports/1271052
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-gv5w-8q25-785v
- https://github.com/nextcloud/server/pull/28078
- https://hackerone.com/reports/1271052
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2021-32800 or the next vulnerability affects your stack