What’s Vulnerable › Vulnerabilities
CVE-2021-32804: Arbitrary File Creation/Overwrite due to insufficient absolute path sanitization
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-22
Description
The npm package "tar" (aka node-tar) before versions 6.1.1, 5.0.6, 4.4.14, and 3.3.2 has a arbitrary File Creation/Overwrite vulnerability due to insufficient absolute path sanitization. node-tar aims to prevent extraction of absolute file paths by turning absolute paths into relative paths when the `preservePaths` flag is not set to `true`. This is achieved by stripping the absolute path root from any absolute file paths contained in a tar file. For example `/home/user/.bashrc` would turn into `home/user/.bashrc`. This logic was insufficient when file paths contained repeated path roots such as `////home/user/.bashrc`. `node-tar` would only strip a single path root from such paths. When given an absolute file path with repeating path roots, the resulting path (e.g. `///home/user/.bashrc`) would still resolve to an absolute path, thus allowing arbitrary file creation and overwrite. This issue was addressed in releases 3.2.2, 4.4.14, 5.0.6 and 6.1.1. Users may work around this vulnerability without upgrading by creating a custom `onentry` method which sanitizes the `entry.path` or a `filter` method which removes entries with absolute paths. See referenced GitHub Advisory for details. Be aware of CVE-2021-32803 which fixes a similar bug in later versions of tar.
Affected products
- Oracle Corporation GraalVM Enterprise Edition: 20.3.3, 21.2.0
- Siemens Sinec Infrastructure Network Services: before 1.0.1.1 — fixed in 1.0.1.1
- Tar Project Tar: before 3.2.2; from 4.0.0 before 4.4.14; from 5.0.0 before 5.0.6; from 6.0.0 before 6.1.1 — fixed in 3.2.2, 4.4.14, 5.0.6, 6.1.1
- Npm Tar: before 3.2.2; from 4.0.0 before 4.4.14; from 5.0.0 before 5.0.6; from 6.0.0 before 6.1.1 — fixed in 3.2.2, 4.4.14, 5.0.6, 6.1.1
How to fix
Upgrade to a fixed version: Siemens Sinec Infrastructure Network Services 1.0.1.1; Tar Project Tar 3.2.2, 4.4.14, 5.0.6, 6.1.1; Npm Tar 3.2.2, 4.4.14, 5.0.6, 6.1.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://github.com/npm/node-tar/commit/1f036ca23f64a547bdd6c79c1a44bc62e8115da4
- https://github.com/npm/node-tar/security/advisories/GHSA-3jfq-g458-7qm9
- https://www.npmjs.com/advisories/1770
- https://www.npmjs.com/package/tar
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://github.com/npm/node-tar/commit/1f036ca23f64a547bdd6c79c1a44bc62e8115da4
- https://github.com/npm/node-tar/security/advisories/GHSA-3jfq-g458-7qm9
- https://www.npmjs.com/advisories/1770
- https://www.npmjs.com/package/tar
- https://www.oracle.com/security-alerts/cpuoct2021.html
Get alerted when CVE-2021-32804 or the next vulnerability affects your stack