What’s Vulnerable › Vulnerabilities
CVE-2021-32808: Cross-site scripting in ckeditor via abuse of undo functionality
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-06-17
- Weakness: CWE-79
Description
ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.
Affected products
- ckeditor4: from 4.13.0 before 4.16.2 — fixed in 4.16.2
- Fedoraproject Fedora: 33, 34, 35
- Oracle Corporation Application Express: before 21.1.4 — fixed in 21.1.4
- Oracle Banking Party Management: 2.7.0
- Oracle Corporation Oracle Commerce Guided Search / Oracle Commerce Experience Manager: 11.3.2
- Oracle Corporation Commerce Merchandising: 11.3.2
- Oracle Documaker: 12.6.3, 12.6.4
- Oracle Corporation Financial Services Analytical Applications Infrastructure: from 8.0.7 through 8.1.1
- Oracle Financial Services Model Management And Governance: 8.0.8.0.0, 8.1.0.0.0
- Oracle Corporation JD Edwards EnterpriseOne Tools: through 9.2.6.0
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.57, 8.58, 8.59
- Oracle Corporation Siebel UI Framework: through 21.9
- Oracle Corporation Oracle WebCenter Sites: 12.2.1.3.0, 12.2.1.4.0
How to fix
Upgrade to a fixed version: ckeditor4 4.16.2; Oracle Corporation Application Express 21.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/ckeditor/ckeditor4/releases/tag/4.16.2
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-6226-h7ff-ch6c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://github.com/ckeditor/ckeditor4/releases/tag/4.16.2
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-6226-h7ff-ch6c
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NYA354LJP47KCVJMTUO77ZCX3ZK42G3T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UVOYN2WKDPLKCNILIGEZM236ABQASLGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WAGNWHFIQAVCP537KFFS2A2GDG66J7XD/
Get alerted when CVE-2021-32808 or the next vulnerability affects your stack