What’s Vulnerable › Vulnerabilities

CVE-2021-32809: Arbitrary HTML injection vulnerability in ckeditor

Description

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.16.2; Oracle Corporation Application Express 21.1.4; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-32809 or the next vulnerability affects your stack