What’s Vulnerable › Vulnerabilities
CVE-2021-32811: Remote Code Execution via Script (Python) objects under Python 3
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-915
Description
Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.
Affected products
- zopefoundation AccessControl: from 4.0 before 4.3; from 5.0 before 5.2 — fixed in 4.3, 5.2
- zopefoundation Zope: from 4.0 before 4.6.3; from 5.0 before 5.3 — fixed in 4.6.3, 5.3
How to fix
Upgrade to a fixed version: zopefoundation AccessControl 4.3, 5.2; zopefoundation Zope 4.6.3, 5.3. Check the vendor advisory for mitigations.
References
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf
- https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf
- https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr
Get alerted when CVE-2021-32811 or the next vulnerability affects your stack