What’s Vulnerable › Vulnerabilities
CVE-2021-32814: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Skytable
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-22
Description
Skytable is a NoSQL database with automated snapshots and TLS. Versions prior to 0.5.1 are vulnerable to a a directory traversal attack enabling remotely connected clients to destroy and/or manipulate critical files on the host's file system. This security bug has been patched in version 0.5.1. There are no known workarounds aside from upgrading.
Affected products
- skytable: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: skytable 0.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/skytable/skytable/blob/next/CHANGELOG.md#version-051-2021-03-17
- https://github.com/skytable/skytable/commit/38b011273bb92b83c61053ae2fcd80aa9320315c#diff-1cdcf1a793c71ec658782437e4da7e3a37042bc1e2c12545942e9a14679c4b7e
- https://github.com/skytable/skytable/security/advisories/GHSA-2hj9-cxmc-m4g7
- https://security.skytable.io/ve/s/00001.html
- https://github.com/skytable/skytable/blob/next/CHANGELOG.md#version-051-2021-03-17
- https://github.com/skytable/skytable/commit/38b011273bb92b83c61053ae2fcd80aa9320315c#diff-1cdcf1a793c71ec658782437e4da7e3a37042bc1e2c12545942e9a14679c4b7e
- https://github.com/skytable/skytable/security/advisories/GHSA-2hj9-cxmc-m4g7
- https://security.skytable.io/ve/s/00001.html
Get alerted when CVE-2021-32814 or the next vulnerability affects your stack