What’s Vulnerable › Vulnerabilities
CVE-2021-32815: Denial of service due to assertion failure in crwimage_int.cpp
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-09 · updated 2026-06-17
- Weakness: CWE-617
Description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The assertion failure is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when modifying the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fi`. ### Patches The bug is fixed in version v0.27.5. ### References Regression test and bug fix: #1739 ### For more information Please see our [security policy](https://github.com/Exiv2/exiv2/security/policy) for information about Exiv2 security.
Affected products
- Debian Linux: 10.0
- exiv2: through 0.27.4
- Fedoraproject Fedora: 33, 34
References
- https://github.com/Exiv2/exiv2/pull/1739
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://security.gentoo.org/glsa/202312-06
- https://github.com/Exiv2/exiv2/pull/1739
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://security.gentoo.org/glsa/202312-06
Get alerted when CVE-2021-32815 or the next vulnerability affects your stack