What’s Vulnerable › Vulnerabilities
CVE-2021-32839: Regular Expression Denial of Service in sqlparse
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-400
Description
sqlparse is a non-validating SQL parser module for Python. In sqlparse versions 0.4.0 and 0.4.1 there is a regular Expression Denial of Service in sqlparse vulnerability. The regular expression may cause exponential backtracking on strings containing many repetitions of '\r\n' in SQL comments. Only the formatting feature that removes comments from SQL statements is affected by this regular expression. As a workaround don't use the sqlformat.format function with keyword strip_comments=True or the --strip-comments command line flag when using the sqlformat command line tool. The issues has been fixed in sqlparse 0.4.2.
Affected products
- andialbrecht sqlparse: from 0.4.0 before 0.4.2 — fixed in 0.4.2
- Pypi Sqlparse: from 0.4.0 before 0.4.2; 0.4.0, 0.4.1 — fixed in 0.4.2
How to fix
Upgrade to a fixed version: andialbrecht sqlparse 0.4.2; Pypi Sqlparse 0.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/andialbrecht/sqlparse/commit/8238a9e450ed1524e40cb3a8b0b3c00606903aeb
- https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-p5w8-wqhj-9hhf
- https://github.com/andialbrecht/sqlparse/commit/8238a9e450ed1524e40cb3a8b0b3c00606903aeb
- https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-p5w8-wqhj-9hhf
- https://lists.debian.org/debian-lts-announce/2024/12/msg00022.html
Get alerted when CVE-2021-32839 or the next vulnerability affects your stack