What’s Vulnerable › Vulnerabilities
CVE-2021-32851: jQuery MiniColors vulnerable to Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Mind-elixir is a free, open source mind map core. Prior to version 0.18.1, mind-elixir is prone to cross-site scripting when handling untrusted menus. This issue is patched in version 0.18.1
Affected products
- npm mind-elixir: before 0.18.1 — fixed in 0.18.1
How to fix
Upgrade to a fixed version: npm mind-elixir 0.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/ssshooter/mind-elixir-core/blob/79942a68b14c8875ab7d270b1ad25bfff351b04c/src/plugin/contextMenu.js#L13
- https://github.com/ssshooter/mind-elixir-core/commit/073485269ac83af24371f35bd08507defa885655
- https://securitylab.github.com/advisories/GHSL-2021-1047_Mind-elixir/
- https://github.com/ssshooter/mind-elixir-core/blob/79942a68b14c8875ab7d270b1ad25bfff351b04c/src/plugin/contextMenu.js#L13
- https://github.com/ssshooter/mind-elixir-core/commit/073485269ac83af24371f35bd08507defa885655
- https://securitylab.github.com/advisories/GHSL-2021-1047_Mind-elixir/
Get alerted when CVE-2021-32851 or the next vulnerability affects your stack