What’s Vulnerable › Vulnerabilities
CVE-2021-32852: countly-server vulnerable to Cross-site Scripting
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Countly, a product analytics solution, is vulnerable to cross-site scripting prior to version 21.11 of the community edition. The victim must follow a malicious link or be redirected there from malicious web site. The attacker must have an account or be able to create one. This issue is patched in version 21.11.
Affected products
- countly-server: before 21.11 — fixed in 21.11
How to fix
Upgrade to a fixed version: countly-server 21.11. Check the vendor advisory for mitigations.
References
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/app.js#L1112
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/views/reset.html#L95
- https://github.com/Countly/countly-server/releases/tag/v21.11
- https://securitylab.github.com/advisories/GHSL-2021-104-countly-server/
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/app.js#L1112
- https://github.com/Countly/countly-server/blob/6b90bb775e747cabe46fe197c6a6989acc6c3417/frontend/express/views/reset.html#L95
- https://github.com/Countly/countly-server/releases/tag/v21.11
- https://securitylab.github.com/advisories/GHSL-2021-104-countly-server/
Get alerted when CVE-2021-32852 or the next vulnerability affects your stack