What’s Vulnerable › Vulnerabilities
CVE-2021-32853: Erxes vulnerable to Cross-site Scripting
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Erxes, an experience operating system (XOS) with a set of plugins, is vulnerable to cross-site scripting in versions 0.22.3 and prior. This results in client-side code execution. The victim must follow a malicious link or be redirected there from malicious web site. There are no known patches.
Affected products
- npm erxes: before 0.22.3 — fixed in 0.22.3
How to fix
Upgrade to a fixed version: npm erxes 0.22.3. Check the vendor advisory for mitigations.
References
- https://github.com/erxes/erxes/blob/f131b49add72032650d483f044d00658908aaf4a/widgets/server/index.ts#L54
- https://github.com/erxes/erxes/blob/f131b49add72032650d483f044d00658908aaf4a/widgets/server/views/widget.ejs#L14
- https://securitylab.github.com/advisories/GHSL-2021-103-erxes/
- https://github.com/erxes/erxes/blob/f131b49add72032650d483f044d00658908aaf4a/widgets/server/index.ts#L54
- https://github.com/erxes/erxes/blob/f131b49add72032650d483f044d00658908aaf4a/widgets/server/views/widget.ejs#L14
- https://securitylab.github.com/advisories/GHSL-2021-103-erxes/
Get alerted when CVE-2021-32853 or the next vulnerability affects your stack