What’s Vulnerable › Vulnerabilities
CVE-2021-32855: vditor vulnerable to Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for this issue.
Affected products
- vanessa219/vditor: before 3.8.7 — fixed in 3.8.7
How to fix
Upgrade to a fixed version: vanessa219/vditor 3.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/Vanessa219/vditor/commit/1b2382d7f8a4ee509d9245db4450d926a0b24146
- https://github.com/Vanessa219/vditor/issues/1085
- https://securitylab.github.com/advisories/GHSL-2021-1006-vditor/
- https://github.com/Vanessa219/vditor/commit/1b2382d7f8a4ee509d9245db4450d926a0b24146
- https://github.com/Vanessa219/vditor/issues/1085
- https://securitylab.github.com/advisories/GHSL-2021-1006-vditor/
Get alerted when CVE-2021-32855 or the next vulnerability affects your stack