What’s Vulnerable › Vulnerabilities
CVE-2021-32937: MDT AutoSave Generation of Error Message Containing Sensitive Information
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-209
Description
An attacker can gain knowledge of a session temporary working folder where the getfile and putfile commands are used in MDT AutoSave versions prior to v6.02.06. An attacker can leverage this knowledge to provide a malicious command to the working directory where the read and write activity can be initiated.
Affected products
- Auvesy-Mdt Autosave: before 6.02.06; from 7.00 through 7.04 — fixed in 6.02.06
- Auvesy-Mdt Autosave For System Platform: before 4.01; 5.00 — fixed in 4.01
How to fix
Upgrade to a fixed version: Auvesy-Mdt Autosave 6.02.06; Auvesy-Mdt Autosave For System Platform 4.01. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-189-02
- https://www.cisa.gov/uscert/ics/advisories/icsa-21-189-02
Get alerted when CVE-2021-32937 or the next vulnerability affects your stack