What’s Vulnerable › Vulnerabilities
CVE-2021-33020: Philips Vue PACS Use of a Key Past its Expiration Date
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-324
Description
Philips Vue PACS versions 12.2.x.x and prior uses a cryptographic key or password past its expiration date, which diminishes its safety significantly by increasing the timing window for cracking attacks against that key.
Affected products
- Philips Myvue: before 12.2.1.5 — fixed in 12.2.1.5
- Philips Speech: before 12.2.8.0 — fixed in 12.2.8.0
- Philips Vue Motion: before 12.2.1.5 — fixed in 12.2.1.5
- Philips Vue PACS: before 12.2.8.0 — fixed in 12.2.8.0
How to fix
Upgrade to a fixed version: Philips Myvue 12.2.1.5; Philips Speech 12.2.8.0; Philips Vue Motion 12.2.1.5; Philips Vue PACS 12.2.8.0. Check the vendor advisory for mitigations.
References
- http://www.philips.com/productsecurity
- https://www.cisa.gov/uscert/ics/advisories/icsma-21-187-01
- http://www.philips.com/productsecurity
- https://www.cisa.gov/uscert/ics/advisories/icsma-21-187-01
Get alerted when CVE-2021-33020 or the next vulnerability affects your stack