What’s Vulnerable › Vulnerabilities
CVE-2021-33027
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-19 · updated 2026-06-17
- Weakness: CWE-331
Description
Sylabs Singularity Enterprise through 1.6.2 has Insufficient Entropy in a nonce.
Affected products
- sylabs singularity: from 1.2.0 before 1.2.6; from 1.3.0 before 1.3.4; from 1.4.0 before 1.4.4; from 1.5.0 before 1.5.4; from 1.6.0 before 1.6.3 — fixed in 1.2.6, 1.3.4, 1.4.4, 1.5.4, 1.6.3
How to fix
Upgrade to a fixed version: sylabs singularity 1.2.6, 1.3.4, 1.4.4, 1.5.4. Check the vendor advisory for mitigations.
References
- https://medium.com/sylabs
- https://support.sylabs.io/a/solutions/articles/42000086439
- https://medium.com/sylabs
- https://support.sylabs.io/a/solutions/articles/42000086439
Get alerted when CVE-2021-33027 or the next vulnerability affects your stack