What’s Vulnerable › Vulnerabilities
CVE-2021-33033
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-08-05
- Weakness: CWE-416
Description
The Linux kernel before 5.11.14 has a use-after-free in cipso_v4_genopt in net/ipv4/cipso_ipv4.c because the CIPSO and CALIPSO refcounting for the DOI definitions is mishandled, aka CID-ad5d07f4a9cd. This leads to writing an arbitrary value.
Affected products
- Linux kernel: from 2.6.28 before 4.9.298; from 4.10 before 4.14.226; from 4.15 before 4.19.181; from 4.20 before 5.4.106; from 5.5 before 5.10.24; from 5.11 before 5.11.7 — fixed in 4.14.226, 4.19.181, 4.9.298, 5.10.24, 5.11.7, 5.4.106
How to fix
Upgrade to a fixed version: Linux kernel 4.14.226, 4.19.181, 4.9.298, 5.10.24. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.14
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.7
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1165affd484889d4986cf3b724318935a0b120d8
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ad5d07f4a9cd671233ae20983848874731102c08
- https://sites.google.com/view/syzscope/kasan-use-after-free-read-in-cipso_v4_genopt
- https://syzkaller.appspot.com/bug?id=96e7d345748d8814901c91cd92084ed04b46701e
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.14
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.11.7
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1165affd484889d4986cf3b724318935a0b120d8
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ad5d07f4a9cd671233ae20983848874731102c08
- https://sites.google.com/view/syzscope/kasan-use-after-free-read-in-cipso_v4_genopt
- https://syzkaller.appspot.com/bug?id=96e7d345748d8814901c91cd92084ed04b46701e
Get alerted when CVE-2021-33033 or the next vulnerability affects your stack