What’s Vulnerable › Vulnerabilities

CVE-2021-33036: Apache Hadoop Privilege escalation vulnerability

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Hadoop 2.10.2, 3.2.3, 3.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33036 or the next vulnerability affects your stack