What’s Vulnerable › Vulnerabilities
CVE-2021-33040
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-79
Description
managers/views/iframe.js in FuturePress EPub.js before 0.3.89 allows XSS.
Affected products
- Futurepress Epub.Js: before 0.3.89 — fixed in 0.3.89
How to fix
Upgrade to a fixed version: Futurepress Epub.Js 0.3.89. Check the vendor advisory for mitigations.
References
- https://github.com/futurepress/epub.js/blob/5c7f21d648d9d20d44c6c365d164b16871847023/src/managers/views/iframe.js#L373
- https://github.com/futurepress/epub.js/commit/ab4dd46408cce0324e1c67de4a3ba96b59e5012e
- https://github.com/futurepress/epub.js/compare/v0.3.88...v0.3.89
- https://github.com/futurepress/epub.js/blob/5c7f21d648d9d20d44c6c365d164b16871847023/src/managers/views/iframe.js#L373
- https://github.com/futurepress/epub.js/commit/ab4dd46408cce0324e1c67de4a3ba96b59e5012e
- https://github.com/futurepress/epub.js/compare/v0.3.88...v0.3.89
Get alerted when CVE-2021-33040 or the next vulnerability affects your stack