What’s Vulnerable › Vulnerabilities
CVE-2021-33054
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-04 · updated 2026-06-17
- Weakness: CWE-347
Description
SOGo 2.x before 2.4.1 and 3.x through 5.x before 5.1.1 does not validate the signatures of any SAML assertions it receives. Any actor with network access to the deployment could impersonate users when SAML is the authentication method. (Only versions after 2.0.5a are affected.)
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Inverse Sogo: from 2.0.6 before 2.4.1; from 3.0.0 before 5.1.1 — fixed in 2.4.1, 5.1.1
How to fix
Upgrade to a fixed version: Inverse Sogo 2.4.1, 5.1.1. Check the vendor advisory for mitigations.
References
- https://blogs.akamai.com/2021/06/sogo-and-packetfence-impacted-by-saml-implementation-vulnerabilities.html
- https://github.com/inverse-inc/sogo/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/07/msg00007.html
- https://www.debian.org/security/2021/dsa-5029
- https://www.sogo.nu/news.html
- https://blogs.akamai.com/2021/06/sogo-and-packetfence-impacted-by-saml-implementation-vulnerabilities.html
- https://github.com/inverse-inc/sogo/blob/master/CHANGELOG.md
- https://lists.debian.org/debian-lts-announce/2021/07/msg00007.html
- https://www.debian.org/security/2021/dsa-5029
- https://www.sogo.nu/news.html
Get alerted when CVE-2021-33054 or the next vulnerability affects your stack