What’s Vulnerable › Vulnerabilities
CVE-2021-3309
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-295
Description
packages/wekan-ldap/server/ldap.js in Wekan before 4.87 can process connections even though they are not authorized by the Certification Authority trust store,
Affected products
- WeKan: before 4.87 — fixed in 4.87
How to fix
Upgrade to a fixed version: WeKan 4.87. Check the vendor advisory for mitigations.
References
- https://github.com/wekan/wekan/issues/3482
- https://github.com/wekan/wekan/pull/3483/commits/31f89121fecca5a761b05cc3a26d4f237e90b484
- https://github.com/wekan/wekan/releases/tag/v4.87
- https://github.com/wekan/wekan/issues/3482
- https://github.com/wekan/wekan/pull/3483/commits/31f89121fecca5a761b05cc3a26d4f237e90b484
- https://github.com/wekan/wekan/releases/tag/v4.87
Get alerted when CVE-2021-3309 or the next vulnerability affects your stack