What’s Vulnerable › Vulnerabilities
CVE-2021-33176
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-502
Description
VerneMQ MQTT Broker versions prior to 1.12.0 are vulnerable to a denial of service attack as a result of excessive memory consumption due to the handling of untrusted inputs. These inputs cause the message broker to consume large amounts of memory, resulting in the application being terminated by the operating system.
Affected products
- vernemq: before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: vernemq 1.12.0. Check the vendor advisory for mitigations.
References
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-rabbitmq-emqx-vernemq
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-rabbitmq-emqx-vernemq
Get alerted when CVE-2021-33176 or the next vulnerability affects your stack