What’s Vulnerable › Vulnerabilities
CVE-2021-33192: Display information UI XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the HTML pages of Apache Jena Fuseki allows an attacker to execute arbitrary javascript on certain page views. This issue affects Apache Jena Fuseki from version 2.0.0 to version 4.0.0 (inclusive).
Affected products
- Apache Software Foundation Apache Jena Fuseki: from 2.0.0 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jena Fuseki 4.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/r684d8943d755a96fe90f8cd8df196737b6bde3f2b74e15a9bd479975%40%3Cusers.jena.apache.org%3E
- https://lists.apache.org/thread.html/r684d8943d755a96fe90f8cd8df196737b6bde3f2b74e15a9bd479975%40%3Cusers.jena.apache.org%3E
Get alerted when CVE-2021-33192 or the next vulnerability affects your stack