What’s Vulnerable › Vulnerabilities

CVE-2021-33195

Description

Go before 1.15.13 and 1.16.x before 1.16.5 has functions for DNS lookups that do not validate replies from DNS servers, and thus a return value may contain an unsafe injection (e.g., XSS) that does not conform to the RFC1035 format.

Affected products

How to fix

Upgrade to a fixed version: Go 1.15.13, 1.16.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33195 or the next vulnerability affects your stack