What’s Vulnerable › Vulnerabilities

CVE-2021-33197

Description

In Go before 1.15.13 and 1.16.x before 1.16.5, some configurations of ReverseProxy (from net/http/httputil) result in a situation where an attacker is able to drop arbitrary headers.

Affected products

How to fix

Upgrade to a fixed version: Go 1.15.13, 1.16.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33197 or the next vulnerability affects your stack