What’s Vulnerable › Vulnerabilities
CVE-2021-33204
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-19 · updated 2026-06-17
Description
In the pg_partman (aka PG Partition Manager) extension before 4.5.1 for PostgreSQL, arbitrary code execution can be achieved via SECURITY DEFINER functions because an explicit search_path is not set.
Affected products
- Pgxn Pg Partman: before 4.5.1 — fixed in 4.5.1
How to fix
Upgrade to a fixed version: Pgxn Pg Partman 4.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pgpartman/pg_partman/commit/0b6565ad378c358f8a6cd1d48ddc482eb7f854d3
- https://github.com/pgpartman/pg_partman/compare/v4.5.0...v4.5.1
- https://security.netapp.com/advisory/ntap-20210625-0006/
- https://github.com/pgpartman/pg_partman/commit/0b6565ad378c358f8a6cd1d48ddc482eb7f854d3
- https://github.com/pgpartman/pg_partman/compare/v4.5.0...v4.5.1
- https://security.netapp.com/advisory/ntap-20210625-0006/
Get alerted when CVE-2021-33204 or the next vulnerability affects your stack