What’s Vulnerable › Vulnerabilities
CVE-2021-33205
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
Description
Western Digital EdgeRover before 0.25 has an escalation of privileges vulnerability where a low privileged user could load malicious content into directories with higher privileges, because of how Node.js is used. An attacker can gain admin privileges and carry out malicious activities such as creating a fake library and stealing user credentials.
Affected products
- Western Digital EdgeRover: before 0.25 — fixed in 0.25
How to fix
Upgrade to a fixed version: Western Digital EdgeRover 0.25. Check the vendor advisory for mitigations.
References
- https://www.westerndigital.com/support/productsecurity/wdc-21007-edgerover-windows-app-ver-0-25
- https://www.westerndigital.com/support/productsecurity/wdc-21007-edgerover-windows-app-ver-0-25
Get alerted when CVE-2021-33205 or the next vulnerability affects your stack