What’s Vulnerable › Vulnerabilities
CVE-2021-33285
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-06-17
- Weakness: CWE-787
Description
In NTFS-3G versions < 2021.8.22, when a specially crafted NTFS attribute is supplied to the function ntfs_get_attribute_value, a heap buffer overflow can occur allowing for memory disclosure or denial of service. The vulnerability is caused by an out-of-bound buffer access which can be triggered by mounting a crafted ntfs partition. The root cause is a missing consistency check after reading an MFT record : the "bytes_in_use" field should be less than the "bytes_allocated" field. When it is not, the parsing of the records proceeds into the wild.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 33, 34, 35
- Red Hat Enterprise Linux: 7.0, 8.0
- Tuxera NTFS-3G: before 2021.8.22 — fixed in 2021.8.22
How to fix
Upgrade to a fixed version: Tuxera NTFS-3G 2021.8.22. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/08/30/1
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=988386
- https://bugzilla.redhat.com/show_bug.cgi?id=2001608
- https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-q759-8j5v-q5jp
- https://lists.debian.org/debian-lts-announce/2021/11/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/766ISTT3KCARKFUIQT7N6WV6T63XOKG3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HSEKTKHO5HFZHWZNJNBJZA56472KRUZI/
- https://security.gentoo.org/glsa/202301-01
- https://www.debian.org/security/2021/dsa-4971
- https://www.openwall.com/lists/oss-security/2021/08/30/1
- http://www.openwall.com/lists/oss-security/2021/08/30/1
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=988386
Get alerted when CVE-2021-33285 or the next vulnerability affects your stack