What’s Vulnerable › Vulnerabilities
CVE-2021-33286
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-07 · updated 2026-07-09
- Weakness: CWE-787
Description
In NTFS-3G versions < 2021.8.22, when a specially crafted unicode string is supplied in an NTFS image a heap buffer overflow can occur and allow for code execution.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Tuxera NTFS-3G: before 2021.8.22 — fixed in 2021.8.22
How to fix
Upgrade to a fixed version: Tuxera NTFS-3G 2021.8.22. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/08/30/1
- https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-q759-8j5v-q5jp
- https://lists.debian.org/debian-lts-announce/2021/11/msg00013.html
- https://security.gentoo.org/glsa/202301-01
- https://www.debian.org/security/2021/dsa-4971
- http://www.openwall.com/lists/oss-security/2021/08/30/1
- https://github.com/tuxera/ntfs-3g/security/advisories/GHSA-q759-8j5v-q5jp
- https://lists.debian.org/debian-lts-announce/2021/11/msg00013.html
- https://security.gentoo.org/glsa/202301-01
- https://www.debian.org/security/2021/dsa-4971
Get alerted when CVE-2021-33286 or the next vulnerability affects your stack