What’s Vulnerable › Vulnerabilities
CVE-2021-33316
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-20
Description
The TRENDnet TI-PG1284i switch(hw v2.0R) prior to version 2.0.2.S0 suffers from an integer underflow vulnerability. This vulnerability exists in its lldp related component. Due to lack of proper validation on length field of ChassisID TLV, by sending a crafted lldp packet to the device, integer underflow would occur and the negative number will be passed to memcpy() later, which may cause buffer overflow or invalid memory access.
Affected products
- TRENDnet Teg-30102Ws Firmware: all versions
- TRENDnet Ti-G102I Firmware: all versions
- TRENDnet Ti-G160I Firmware: all versions
- TRENDnet Ti-G642I Firmware: all versions
- TRENDnet Ti-Pg102I Firmware: all versions
- TRENDnet Ti-Pg1284I Firmware: before 2.0.2.s0 — fixed in 2.0.2.s0
- TRENDnet Ti-Pg541I Firmware: all versions
- TRENDnet Ti-Rp262I Firmware: all versions
- TRENDnet Tpe-30102Ws Firmware: all versions
How to fix
Upgrade to a fixed version: TRENDnet Ti-Pg1284I Firmware 2.0.2.s0. Check the vendor advisory for mitigations.
References
- https://www.trendnet.com/support/view.asp?cat=4&id=81
- https://www.trendnet.com/support/view.asp?cat=4&id=81
Get alerted when CVE-2021-33316 or the next vulnerability affects your stack