What’s Vulnerable › Vulnerabilities
CVE-2021-3336
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-29 · updated 2026-06-17
- Weakness: CWE-295
Description
DoTls13CertificateVerify in tls13.c in wolfSSL before 4.7.0 does not cease processing for certain anomalous peer behavior (sending an ED22519, ED448, ECC, or RSA signature without the corresponding certificate). The client side is affected because man-in-the-middle attackers can impersonate TLS 1.3 servers.
Affected products
- wolfSSL: before 4.7.0 — fixed in 4.7.0
How to fix
Upgrade to a fixed version: wolfSSL 4.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/3676
- https://www.wolfssl.com/docs/security-vulnerabilities
- https://github.com/wolfSSL/wolfssl/pull/3676
- https://www.wolfssl.com/docs/security-vulnerabilities
Get alerted when CVE-2021-3336 or the next vulnerability affects your stack