What’s Vulnerable › Vulnerabilities
CVE-2021-33430: NumPy Buffer Overflow (Disputed)
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-17 · updated 2026-06-17
- Weakness: CWE-120
Description
A Buffer Overflow vulnerability exists in NumPy 1.9.x in the PyArray_NewFromDescr_int function of ctors.c when specifying arrays of large dimensions (over 32) from Python code, which could let a malicious user cause a Denial of Service. NOTE: The vendor does not agree this is a vulneraility; In (very limited) circumstances a user may be able provoke the buffer overflow, the user is most likely already privileged to at least provoke denial of service by exhausting memory. Triggering this further requires the use of uncommon API (complicated structured dtypes), which is very unlikely to be available to an unprivileged user
Affected products
- Numpy: from 1.9.0 through 1.9.3
- Pypi Numpy: from 1.9.0 before 1.21; 1.10.0, 1.10.1, 1.10.2, 1.10.3, 1.10.4, 1.11.0 (+53) — fixed in 1.21
How to fix
Upgrade to a fixed version: Pypi Numpy 1.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-33430 or the next vulnerability affects your stack