What’s Vulnerable › Vulnerabilities

CVE-2021-33514

Description

Certain NETGEAR devices are affected by command injection by an unauthenticated attacker via the vulnerable /sqfs/lib/libsal.so.0.0 library used by a CGI application, as demonstrated by setup.cgi?token=';$HTTP_USER_AGENT;' with an OS command in the User-Agent field. This affects GC108P before 1.0.7.3, GC108PP before 1.0.7.3, GS108Tv3 before 7.0.6.3, GS110TPPv1 before 7.0.6.3, GS110TPv3 before 7.0.6.3, GS110TUPv1 before 1.0.4.3, GS710TUPv1 before 1.0.4.3, GS716TP before 1.0.2.3, GS716TPP before 1.0.2.3, GS724TPPv1 before 2.0.4.3, GS724TPv2 before 2.0.4.3, GS728TPPv2 before 6.0.6.3, GS728TPv2 before 6.0.6.3, GS752TPPv1 before 6.0.6.3, GS752TPv2 before 6.0.6.3, MS510TXM before 1.0.2.3, and MS510TXUP before 1.0.2.3.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR Gc108P Firmware 1.0.7.3; NETGEAR Gc108Pp Firmware 1.0.7.3; NETGEAR Gs108T Firmware 7.0.6.3; NETGEAR Gs110Tp Firmware 7.0.6.3; NETGEAR Gs110Tpp Firmware 7.0.6.3; NETGEAR Gs110Tup Firmware 1.0.4.3; NETGEAR Gs710Tup Firmware 1.0.4.3; NETGEAR Gs716Tp Firmware 1.0.2.3; NETGEAR Gs716Tpp Firmware 1.0.2.3; NETGEAR Gs724Tp Firmware 2.0.4.3; NETGEAR Gs724Tpp Firmware 2.0.4.3; NETGEAR Gs728Tp Firmware 6.0.6.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33514 or the next vulnerability affects your stack