What’s Vulnerable › Vulnerabilities
CVE-2021-33516
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-24 · updated 2026-06-17
Description
An issue was discovered in GUPnP before 1.0.7 and 1.1.x and 1.2.x before 1.2.5. It allows DNS rebinding. A remote web server can exploit this vulnerability to trick a victim's browser into triggering actions against local UPnP services implemented using this library. Depending on the affected service, this could be used for data exfiltration, data tempering, etc.
Affected products
- GNOME Gupnp: before 1.0.7; from 1.1.0 before 1.2.5 — fixed in 1.0.7, 1.2.5
How to fix
Upgrade to a fixed version: GNOME Gupnp 1.0.7, 1.2.5. Check the vendor advisory for mitigations.
References
- https://discourse.gnome.org/t/security-relevant-releases-for-gupnp-issue-cve-2021-33516/6536
- https://gitlab.gnome.org/GNOME/gupnp/-/issues/24
- https://discourse.gnome.org/t/security-relevant-releases-for-gupnp-issue-cve-2021-33516/6536
- https://gitlab.gnome.org/GNOME/gupnp/-/issues/24
Get alerted when CVE-2021-33516 or the next vulnerability affects your stack