What’s Vulnerable › Vulnerabilities

CVE-2021-33560

Description

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

Affected products

How to fix

Upgrade to a fixed version: gnupg Libgcrypt 1.8.8, 1.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33560 or the next vulnerability affects your stack