What’s Vulnerable › Vulnerabilities
CVE-2021-33561
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability in Shopizer before 2.17.0 allows remote attackers to inject arbitrary web script or HTML via customer_name in various forms of store administration. It is saved in the database. The code is executed for any user of store administration when information is fetched from the backend, e.g., in admin/customers/list.html.
Affected products
- shopizer-ecommerce Shopizer: before 2.17.0 — fixed in 2.17.0
How to fix
Upgrade to a fixed version: shopizer-ecommerce Shopizer 2.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/shopizer-ecommerce/shopizer/commit/197f8c78c8f673b957e41ca2c823afc654c19271
- https://github.com/shopizer-ecommerce/shopizer/compare/2.16.0...2.17.0
- https://www.exploit-db.com/exploits/49901
- https://github.com/shopizer-ecommerce/shopizer/commit/197f8c78c8f673b957e41ca2c823afc654c19271
- https://github.com/shopizer-ecommerce/shopizer/compare/2.16.0...2.17.0
- https://www.exploit-db.com/exploits/49901
Get alerted when CVE-2021-33561 or the next vulnerability affects your stack