What’s Vulnerable › Vulnerabilities
CVE-2021-33564
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 72.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-29 · updated 2026-06-17
- Weakness: CWE-88
Description
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
Affected products
- Dragonfly Project Dragonfly: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Dragonfly Project Dragonfly 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/markevans/dragonfly/commit/25399297bb457f7fcf8e3f91e85945b255b111b5
- https://github.com/markevans/dragonfly/compare/v1.3.0...v1.4.0
- https://github.com/markevans/dragonfly/issues/513
- https://github.com/mlr0p/CVE-2021-33564
- https://raw.githubusercontent.com/projectdiscovery/nuclei-templates/master/cves/2021/CVE-2021-33564.yaml
- https://zxsecurity.co.nz/research/argunment-injection-ruby-dragonfly/
- https://github.com/markevans/dragonfly/commit/25399297bb457f7fcf8e3f91e85945b255b111b5
- https://github.com/markevans/dragonfly/compare/v1.3.0...v1.4.0
- https://github.com/markevans/dragonfly/issues/513
- https://github.com/mlr0p/CVE-2021-33564
- https://raw.githubusercontent.com/projectdiscovery/nuclei-templates/master/cves/2021/CVE-2021-33564.yaml
- https://zxsecurity.co.nz/research/argunment-injection-ruby-dragonfly/
Get alerted when CVE-2021-33564 or the next vulnerability affects your stack