What’s Vulnerable › Vulnerabilities
CVE-2021-33620
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 79.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Squid before 4.15 and 5.x before 5.0.6 allows remote servers to cause a denial of service (affecting availability to all clients) via an HTTP response. The issue trigger is a header that can be expected to exist in HTTP traffic without any malicious intent by the server.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 33, 34
- Squid: before 4.15; from 5.0 before 5.0.6 — fixed in 4.15, 5.0.6
How to fix
Upgrade to a fixed version: Squid 4.15, 5.0.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-1e05a85bd28c22c9ca5d3ac9f5e86d6269ec0a8c.patch
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-8af775ed98bfd610f9ce762fe177e01b2675588c.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-572g-rvwr-6c7f
- https://lists.debian.org/debian-lts-announce/2021/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSQ3U54ZCNXR44QRPW3AV2VCS6K3TKCF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T4EPIWUZDJAXADDHVOPKRBTQHPBR6H66/
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-1e05a85bd28c22c9ca5d3ac9f5e86d6269ec0a8c.patch
- http://www.squid-cache.org/Versions/v5/changesets/squid-5-8af775ed98bfd610f9ce762fe177e01b2675588c.patch
Get alerted when CVE-2021-33620 or the next vulnerability affects your stack