What’s Vulnerable › Vulnerabilities

CVE-2021-33621

Description

The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

Affected products

How to fix

Upgrade to a fixed version: ruby-lang CGI 0.1.0.2, 0.2.2, 0.3.5; Ruby 2.7.7, 3.0.5, 3.1.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-33621 or the next vulnerability affects your stack