What’s Vulnerable › Vulnerabilities
CVE-2021-33742: Windows MSHTML Platform Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 59.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-787
Description
Windows MSHTML Platform Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 Version 1507: before 10.0.10240.18967 — fixed in 10.0.10240.18967
- Microsoft Windows 10 1607: before 10.0.14393.4467 — fixed in 10.0.14393.4467
- Microsoft Windows 10: before 10.0.17763.1999 — fixed in 10.0.17763.1999
- Microsoft Windows 10 1909: before 10.0.18363.1621 — fixed in 10.0.18363.1621
- Microsoft Windows 10 2004: before 10.0.19041.1052 — fixed in 10.0.19041.1052
- Microsoft Windows 10 20H2: before 10.0.19042.1052 — fixed in 10.0.19042.1052
- Microsoft Windows 10 21H1: before 10.0.19043.1052 — fixed in 10.0.19043.1052
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1, sp2
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: before 10.0.14393.4467 — fixed in 10.0.14393.4467
- Microsoft Windows Server 2019: before 10.0.17763.1999 — fixed in 10.0.17763.1999
- Microsoft Windows 10 Version 1507: from 10.0.0 before 10.0.10240.18967 — fixed in 10.0.10240.18967
- Microsoft Windows 10 1607: from 10.0.0 before 10.0.14393.4467 — fixed in 10.0.14393.4467
- Microsoft Windows 10: from 10.0.0 before 10.0.17763.1999 — fixed in 10.0.17763.1999
- Microsoft Windows 10 1909: from 10.0.0 before 10.0.18363.1621 — fixed in 10.0.18363.1621
- Microsoft Windows 10 2004: from 10.0.0 before 10.0.19041.1052 — fixed in 10.0.19041.1052
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1052 — fixed in 10.0.19042.1052
- Microsoft Windows 10 21H1: from 10.0.0 before 10.0.19043.1052 — fixed in 10.0.19043.1052
- Microsoft Windows 7: from 6.1.0 before 6.1.7601.25632; from 6.1.0 before publication — fixed in 6.1.7601.25632, publication
- Microsoft Windows 7 Service Pack 1: from 6.1.0 before 6.1.7601.25632; from 6.1.0 before publication — fixed in 6.1.7601.25632, publication
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20045; from 6.3.0 before 1.0.0.0 — fixed in 6.3.9600.20045, 1.0.0.0
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.0 before 6.1.7601.25632; from 6.1.0 before publication — fixed in 6.1.7601.25632, publication
- Microsoft Windows Server 2008 Service Pack 2: from 6.0.0 before 6.0.6003.21137; from 6.0.0 before publication — fixed in 6.0.6003.21137, publication
- Microsoft Windows Server 2012: from 6.2.0 before 6.2.9200.23372; from 6.2.0 before 1.0.0.0 — fixed in 6.2.9200.23372, 1.0.0.0
- Microsoft Windows Server 2012 R2: from 6.3.0 before 6.3.9600.20045; from 6.3.0 before 1.0.0.0 — fixed in 6.3.9600.20045, 1.0.0.0
- Microsoft Windows Server 2016: from 10.0.0 before 10.0.14393.4467 — fixed in 10.0.14393.4467
- Microsoft Windows Server 2019: from 10.0.0 before 10.0.17763.1999 — fixed in 10.0.17763.1999
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.18967; Microsoft Windows 10 1607 10.0.14393.4467; Microsoft Windows 10 10.0.17763.1999; Microsoft Windows 10 1909 10.0.18363.1621; Microsoft Windows 10 2004 10.0.19041.1052; Microsoft Windows 10 20H2 10.0.19042.1052; Microsoft Windows 10 21H1 10.0.19043.1052; Microsoft Windows Server 2016 10.0.14393.4467; Microsoft Windows Server 2019 10.0.17763.1999; Microsoft Windows 10 Version 1507 10.0.10240.18967; Microsoft Windows 10 1607 10.0.14393.4467; Microsoft Windows 10 10.0.17763.1999. Check the vendor advisory for mitigations.
References
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-33742
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-33742
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-33742
Get alerted when CVE-2021-33742 or the next vulnerability affects your stack