What’s Vulnerable › Vulnerabilities
CVE-2021-3377
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Affected products
- Ansi Up Project Ansi Up: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Ansi Up Project Ansi Up 5.0.0. Check the vendor advisory for mitigations.
References
- https://doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf
- https://github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27
- https://doyensec.com/resources/Doyensec_Advisory_ansi_up4_XSS.pdf
- https://github.com/drudru/ansi_up/commit/c8c726ed1db979bae4f257b7fa41775155ba2e27
- https://security.netapp.com/advisory/ntap-20241108-0002/
Get alerted when CVE-2021-3377 or the next vulnerability affects your stack